Netbeans Antlr - plugin detail

Supports Antlr v4, provide real time compile for your antlr grammer and test it by specific any file, showing the token, parse tree, etc...

n/a
Plugin owner: mcheung63
Website: https://gitlab.com/mcheung63/netbeans-antlr
Added: 2017-10-17
License: Apache
Category: Programming Languages
Downloaded: 490 times
Rating:
 0, by 0 users

Plugin Log Show log

Versions available

Download plugin   Download size: 27.30 MB   Last Update: 2018-05-03

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

add non token to token table

Verifications for NetBeans versions

8.2 verification PASSED See verification details


Introduction

Just a netbeans plugin for Antlr

[ You have to be logged in to be able to comment. ]

User Comments

  

Confused...

I cannot find solid information on how to actual get the compilation working, please can you help? Can you please provide a set of simple step-by-step instructions? Thank you.

EDIT

OK, I figured it now. The "Set real time compile" option should be set to the file you wish to test the grammar on. This has to be a file currently open in Netbeans.
The "Set dot path" option refers to the dot program from the Graphviz suite, which is needed for the tree diagrams etc.
Posted by sgparry on May 25, 2018
  

can you email me your g4 please

hey marshall.b.woodson, can you email me your g4 please? mchenug63@hotmail.com
Posted by mcheung63 on Dec 05, 2017
  

java.lang.NullPointerException received

I received a java.lang.NullPointerException notification after loading a .g4 file and clicking on the "settings" tab. Not clear to me what I need to do to get this working. Looks like a great plugin, please keep working on it.
Posted by marshall.b.woodson on Nov 18, 2017
  

Please increase the number next time

Because of this bugfix, you should create a new version. 1.0.1. I deactived my plugin, after I tried to install the new version it says, that the plugin is already there, because of the same number. Now I have to uninstall it -> restart NetBeans -> Install the new version. Please be aware of this next time. Thx :)
Posted by ChrisLE on Nov 13, 2017
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo